Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (7)

    Join Date
    Dec 2001
    Location
    Kentucky
    Posts
    1,137

    Default my xlr cable problem

    I recently sent back to Bettercable a set of xlr cables thinking that there is something wrong with them.I had 3 different amps that where defective,hum-buzz so loud that it hurt your ears. Now I have a Ati 3007 amp & its great,Im using rca cable since the xlr cables are being looked at by Bettercables.If they tell me the cables are okay should I be affraid to use them? Could the 3 amps been defective or was it the xlr cables? Bettercables said that they had never heard of there cables or any other brand causing that kind of a problem.What do all of you think? thanks didnt mean to be so long winded.
    My HT set-up Panasonic front proj, 120 in ws screen, ATI amp,Integra 9.8 pre-pro, 2 Polk rti150, cp 1000, 4 fx 1000, Pioneer blu-ray 2 SVS sub pb 12-ultra 2, & Paragon popcorn popper. ps 3 Coaster leather HT recliners.

  2. #2

    Member Sales Rating: (1)

    Join Date
    Nov 2005
    Location
    Chicago Suburbs (Northern)
    Posts
    39

    Default

    I would think that three amps being "defective" is a whole lot less likely than the cables being bad. All it takes is a little shred or a single strand of shielding contacting the conductor and you'll get hum or interference of some sort. Defects can happen in anything, but in three things in a row?

  3. #3

    Member Sales Rating: (58)

    Join Date
    Feb 2003
    Location
    6 Underground
    Posts
    25,306

    Default

    I recently had one of my MIT cables develop a short at the termination, from average use. I've heard of many Audioquest cables with issues so it's certainly within the realm of possibility.

    I concur with Scooter, that's HIGHLY unlikely.

  4. #4

    Member Sales Rating: (7)

    Join Date
    Dec 2001
    Location
    Kentucky
    Posts
    1,137

    Default

    Thanks
    My HT set-up Panasonic front proj, 120 in ws screen, ATI amp,Integra 9.8 pre-pro, 2 Polk rti150, cp 1000, 4 fx 1000, Pioneer blu-ray 2 SVS sub pb 12-ultra 2, & Paragon popcorn popper. ps 3 Coaster leather HT recliners.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. hooking up subwoofer to reciever - cable problem ?
    By pmontagne in forum Troubleshooting
    Replies: 2
    Last Post: 12-21-2006, 11:29 PM
  2. SDA 2Bs Cable Problem
    By marly421 in forum Troubleshooting
    Replies: 5
    Last Post: 10-17-2006, 11:40 PM
  3. possible cable problem???
    By jabrax in forum Troubleshooting
    Replies: 6
    Last Post: 06-05-2006, 08:45 PM
  4. Fritz'd cable hookup problem
    By michael_w in forum Basic Hookup/Wiring Questions
    Replies: 4
    Last Post: 10-15-2005, 05:02 AM
  5. G-Loop problem and it's not the cable TV
    By gwh in forum Electronics
    Replies: 2
    Last Post: 08-16-2005, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts