Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jul 2006
    Posts
    131

    Exclamation Question- Subwoofer making strange noise....??

    Alright, I got a 12" Pioneer Sub, 400 Watts. I have had this for awhile, it was given to me. I really don't know how to explain the sound. Its like a low screech mixed with a crackle. Is it done for good or can it be fixed? If so, can I do it myself. Thanks guys.

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jul 2006
    Posts
    135

    Default

    it sounds blown get a new one

  3. #3

    Member Sales Rating: (0)

    Join Date
    Nov 2003
    Location
    Dayton, OH
    Posts
    3,459

    Default

    that sounds pretty dead to me... try gently pushing on the center of the cone, if it feels gritty or makes a sound, it's certainly gone...

    unfortunately, it cannot be fixed, it will have to be replaced
    It's not good, very fundamentally simply not good. - geolemon

    "Its not good enough until we have real-time fearmongering. I want my fear mongered as it happens." - Shizelbs

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jul 2006
    Posts
    131

    Default

    Quote Originally Posted by neomagus00 View Post
    that sounds pretty dead to me... try gently pushing on the center of the cone, if it feels gritty or makes a sound, it's certainly gone...

    unfortunately, it cannot be fixed, it will have to be replaced
    Alright. I thought it was dead but just checking. But ya its gone.

  5. #5

    Member Sales Rating: (2)

    Join Date
    Sep 2003
    Location
    Kansas
    Posts
    7,522

    Default

    add more airholes :p

  6. #6

    Member Sales Rating: (0)

    Join Date
    May 2009
    Posts
    1

    Angry My speakers are making noises

    Well i have an after market sony xplod head unit.
    And everytime i raise the volume these screeching noises will occur out of the speakers.

    I'd lower the volume all the way and it is still there.
    Only goes away when head unit is off.

    Also this only occurs when the car is running, or while driving.

    1999 Escort zx2.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Lutron IR dimmer making noise.
    By del44 in forum Basic Hookup/Wiring Questions
    Replies: 2
    Last Post: 02-25-2007, 06:20 PM
  2. 12" Pioneer Sub is making a weird noise.....
    By T_Unit616 in forum Car Subwoofer Talk
    Replies: 5
    Last Post: 08-05-2006, 10:03 PM
  3. momo's making a weird noise
    By alon in forum Car Subwoofer Talk
    Replies: 7
    Last Post: 08-15-2003, 08:35 PM
  4. Subwoofer making horrible grinding noise
    By Davemusic in forum Troubleshooting
    Replies: 7
    Last Post: 05-28-2003, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts