Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 31 to 60 of 101
  1. #31

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Now im PISSSSSEDDD!!!! my 3rd one just broke today same problem broken lead wire POLK AUDIO we have a problem. I have had many of subs from dirt cheap to very expensive and have never broken the lead wire. Very unhappy customer here!!!!!! Who wants to buy my other SR124 so I can go buy some reliable JL W6's
    Last edited by greg2350; 02-09-2008 at 04:54 PM.

  2. #32

    Member Sales Rating: (0)

    Join Date
    May 2004
    Location
    San Diego, Ca
    Posts
    2,093

    Default

    I would be very upset as well....
    Alpine: CDA-7949
    Alpine: PXA-H600
    Alpine: CHA-S624, KCA-420i, KCA-410C
    Rainbow: CS 265 Profi Phase Plug / SL 165
    ARC Audio: 4150-XXK / 1500v1-XXK
    JL Audio: 10W6v2 (x2)
    KnuKonceptz
    Second Skin

  3. #33

    Member Sales Rating: (0)

    Join Date
    Sep 2003
    Location
    MN
    Posts
    60

    Default

    Its an awfully silly problem on such a high end 'theoretically' well designed woofer. If I break my third I'll be getting something else too...maybe CDT.
    Pioneer Premier DEH-P980BT
    Alpine SPX-137R
    Alpine SPR-69LP
    Panasonic CY-PA4003U
    Kenwood KAC-X520
    Polk SR124
    :D

  4. #34

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Ok upon further investigation my lead wire broke at the terminal block. I also noticed the insulation is cracked and bare wire is showing where it goes to the voice coil this is not good POLK. I beleive the lead wires are deffective or just plain cheap shame on you POLK AUDIO. I am running a single c500.1 to 2 SR124 svc so i know im not overpowering them, gains are set right I used a scope.
    Last edited by greg2350; 02-10-2008 at 01:26 PM.

  5. #35

    Member Sales Rating: (0)

    Join Date
    Dec 2006
    Location
    Canada
    Posts
    649

    Default

    I hope nothing happens to my subs!

  6. #36

    Member Sales Rating: (0)

    Join Date
    Sep 2003
    Location
    MN
    Posts
    60

    Default

    That is the same problem I found on the last woofer. The insulation cracked off the leads at the point at which they enter the cone. The insulation seems to be rather hard and inflexible and I think it results in an open circuit failure. I really hope there is some sort of recall.
    Pioneer Premier DEH-P980BT
    Alpine SPX-137R
    Alpine SPR-69LP
    Panasonic CY-PA4003U
    Kenwood KAC-X520
    Polk SR124
    :D

  7. #37

    Member Sales Rating: (0)

    Join Date
    Dec 2006
    Location
    Canada
    Posts
    649

    Default

    anybody have this problem with dvc subs?

  8. #38
    lucienph
    Guest

    Default

    Hello,

    I have the same problem! :( two times the speaker stops playing because the lead between the terminal and voice coil snapped/de-soldered. The first time it was because the weak solder.. (POLK?? THIS IS A BIG MISTAKE!!!) Now it's broken again but at the other side of the lead..(conus) I can't repair the woofer and also a servicepiont here in the netherlands (MENO ESM) can't fix it becaus they need a new cone for it.

    I send Polk Audio over and over many emails but no reaction.. I'ts a nice subwoofer but my trust for Polk Audio is gone! I tell anyone about this serious problem and I hope they get the message.

    Polk you better give a good service! Here in the Netherlands we don't accept your kind of communication...
    Last edited by lucienph; 02-12-2008 at 11:48 AM.

  9. #39

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    This is not good POLK AUDIO these are the most expensive subs I have ever purchased and have turned out to be the most unreliable subs I have owned. I to have emailed POLK AUDIO several times with no response NOT GOOD!!!!! I hope they recognize there is a problem with the lead wires on these subs. If another one breaks I will be switching to JL and throw these in the trash.

  10. #40
    lucienph
    Guest

    Default

    greg2350 I feel your powerlessness and disappointment. Same for me.. No reaction from Polk.. My dad gets a special soldering iron from his work and also new wires and then he fix the speaker himself. I'm lucky he works for Pioneer as a engineer. But there is one promise I have to make... Sell the Polk and never buy Polk again!!

    I like Pioneer a lot but they sell more SPL products.. I will go for the JL Audio 12W7.. I don't know what else I can get to have the deepest sound.

    I hope my dad can fix the Polk tonight so I can test it and sell it for less. Polk it's about time you responde!
    Last edited by lucienph; 02-13-2008 at 06:15 AM.

  11. #41
    lucienph
    Guest

    Default

    Or maybe a Orion HCCA 12.4 but I think this is also more SPL..

  12. #42
    Polk Customer Service
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    723

    Default

    Return the blown SR subwoofer to our service department for exchange. The address is Polk Audio 2550 Britannia Boulevard Suite A San Diego, CA. 92154. Include a short note with your name, address, daytime telephone number, description of the problem, along with a copy of your receipt. We recommend shipping it using UPS or FedEx.

    Thanks,
    Kim

  13. #43

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Thanks for the response kim but im getting a little tired of returning my subs only to get another one that eventually has the same problem. Just to clarify the sub is not blown the lead wire keeps breaking if you read this thread you will see others are having the same problem broken lead wire. Thanks again but no thanks I will be switching to JL subs at least I will have the peace of mind knowing the lead wire is not going to break. I love the sound of the sr's but im tired of returning them. Let me know when POLK AUDIO fixes the problem then maybe I will go back to the SR's.

  14. #44
    Polk Customer Service
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    723

    Default

    greg2350 and lucienph,
    Call us at 800-377-7655 and we can help with your SR124 subwoofer problems.

    Thanks,
    Kim

  15. #45

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,815

    Default

    Give Polk a chance to make it right. **** happens some times and some glitches can slip thru the cracks especially on the first run of a new line. Polk hasnt lasted 35 years by making shoddy gear and I dont doubt theyll get this squared away.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  16. #46

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    MacLeod I will always be a loyal polk customer but after the 3rd sub and others reporting the same problem I just want to wait until they fix the problem before I keep sending my sub back and get another one to only have the same problem. I love the sound of these subs but to constantly breaking the lead wire there is a problem. Like I said before I have had many subs and have never had the leads break until now, I have burnt voice coils but never broken the lead wire. I will give polk a chance but until the problem is resolved im not going to keep sending them back every few months. Again I love polk and will always be a loyal customer but until this problem is resolved im forced to try some other subs.:)

  17. #47
    Engineering Technical Services Manager
    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Location
    Polk HQ Baltimore, MD
    Posts
    40

    Default

    Hey guys,
    Please call Kim @ Polk CS he would like to discuss the problem further.
    We work very hard to avoid such problems. ALL Polkaudio products are subjected to extensive testing during product development and throughout the product life. We WILL correct any issue that rears it's ugly head.


    Len

  18. #48

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Thanks for the response Len I will give kim a call and I would like to know what you mean by extensive testing. The longest I have had one last is 4 months and I dont abuse them this is at moderate volume levels. I have noticed the lead wire coming from the voice coil the insulation is cracked on both leads right where they leave the voice coil. The 2 I had break broke where they connect to the terminal block I resoldered but the wire kept breaking and evuntally the wire got 2 short to resolder. I am using a C500.1 running 2 SR124 SVC so I know im not overpowering and I set my gains using a oscciliscope so no clipping here, again thanks for the response. I hope we can get to the root of the problem because I love the sound of these subs and dont want to be forced to another brand, but will be if this problem doesnt get resolved.:):)

  19. #49

    Member Sales Rating: (0)

    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    400

    Default

    greg please let us know what happened, i also have a SR sub, and i dont want it to blow
    /////Alpine CDA-9887 HU
    /////Alpine KTX-1000EQ
    /////Alpine PDX-4.100
    /////Alpine PDX-1.1000
    Polk Audio SR 6500
    Polk Audio SR 124 DVC
    KnuKonceptz Kristal Kable

  20. #50

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    I just spoke to kim on the phone he says they have found the cause of the problem and have fixed the issue. POLK is sending me 2 new subs WOW!!! awesome customer support thanks again kim he was great. If anyone else is experiencing this problem give kim a call and he will take care of you. Kudos to POLK AUDIO and kim.:):)

  21. #51

    Member Sales Rating: (0)

    Join Date
    Sep 2003
    Location
    MN
    Posts
    60

    Default

    I knew I should have called earlier today! now I have to wait until next week. Thank God its been figured out.
    Pioneer Premier DEH-P980BT
    Alpine SPX-137R
    Alpine SPR-69LP
    Panasonic CY-PA4003U
    Kenwood KAC-X520
    Polk SR124
    :D

  22. #52
    Engineering Technical Services Manager
    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Location
    Polk HQ Baltimore, MD
    Posts
    40

    Smile

    The subs don't blow !!!!!!!! No worry there, the failure involved the application of the insulation material used on the tinsel lead and has been resolved. :D

  23. #53

    Member Sales Rating: (0)

    Join Date
    Mar 2006
    Location
    Philippines
    Posts
    393

    Default

    glad to hear the issue has been resolved :)

  24. #54

    Member Sales Rating: (0)

    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    400

    Default

    hey thats so cool kudos for polk
    /////Alpine CDA-9887 HU
    /////Alpine KTX-1000EQ
    /////Alpine PDX-4.100
    /////Alpine PDX-1.1000
    Polk Audio SR 6500
    Polk Audio SR 124 DVC
    KnuKonceptz Kristal Kable

  25. #55

    Member Sales Rating: (0)

    Join Date
    Nov 2007
    Posts
    27

    Default

    So, do all the SR subs up until now have this problem? Because I bought a pair of SR124-DVCs back in November and have had them in for about 2 months and haven't really started pushing them until recently (past week or so) and I'd hate to run into the same problem.

  26. #56

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Bruizer I would give kim a call and have him check the serial numbers on your subs.

  27. #57

    Member Sales Rating: (0)

    Join Date
    Dec 2006
    Location
    Canada
    Posts
    649

    Default

    Quote Originally Posted by Bruizer View Post
    So, do all the SR subs up until now have this problem? Because I bought a pair of SR124-DVCs back in November and have had them in for about 2 months and haven't really started pushing them until recently (past week or so) and I'd hate to run into the same problem.
    I was wondering the same thing. But I've had mine since the summer. I've pounded them a little bit and haven't had a problem yet.

  28. #58

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Black magic take 1 of the subs out and check the insulation on the lead wires if you see any cracking I would say it was a matter of time before it breaks. If you dont see any cracks I would say you were safe. Mine started cracking about 2 to 3 months into use light use.:)

  29. #59

    Member Sales Rating: (0)

    Join Date
    Dec 2006
    Location
    Canada
    Posts
    649

    Default

    Thanks. I'll check it out.

  30. #60

    Member Sales Rating: (5)

    Join Date
    Oct 2004
    Location
    Hot Springs,Arkanasas
    Posts
    555

    Default

    Received my 2 new subs today the insulation does look different. Thanks to POLK AUDIO for correcting the problem and taking care of me. Thanks to kim great to deal with I challenge any company to beat POLK AUDIO customer service top notch again THANKS.:):)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Dual Polk Audio Sr124 enclosure recomendation?
    By moreyb22 in forum Car Subwoofer Talk
    Replies: 27
    Last Post: 09-01-2009, 06:00 PM
  2. Polk SR124-DVC with Alpine PDX-1.1000
    By Kinetic in forum Car Subwoofer Talk
    Replies: 10
    Last Post: 12-13-2007, 07:02 AM
  3. Possible Blue LCD panel failing?
    By mutelight in forum Electronics
    Replies: 3
    Last Post: 10-24-2007, 10:48 AM
  4. Polk Audio/ Onkyo 5.1 Home Theater < 3 months old
    By crazy in forum For Sale (FS) Classifieds
    Replies: 1
    Last Post: 04-18-2006, 10:39 AM
  5. Polk SR124-DVC vs JL Audio W6v2
    By DAlba in forum Car Audio & Electronics
    Replies: 27
    Last Post: 03-18-2006, 10:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts