Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Posts
    2

    Default Monitor 50 - trouble with hooking up wires ???

    Well.. i tried hooking up the speakers to my reciever.. and i just dont get it.. it seems to produce either sounds from just the treble speakers or just the bass speakers or a mix of one treble and one bass depending on how i wire it but it seems no matter what way i do it i cant get both the bass and treble on both speakers ( the right way)

    i dont know if i remember ever seeing those two wire outputs on each speaker.. i thought in the past i only saw one and i think thats why its not working correctly because i only have inputs for two on each speaker.. otherwise itd have to be hooked up to my (B) speaker inputs rather than (A) and it seems to only work correctly using one or the other, not both.. so yeah i dunno if anyone else ran into this problem or if its just me and i dont know if you even understand what im saying but im trying.. haha.. hopefully someone can help me out. thank you.

  2. #2

    Member Sales Rating: (11)

    Join Date
    Jul 2001
    Location
    Spokane, Washington
    Posts
    15,835

    Default

    ummm. sounds like you are missing the metal jumpers that go between the upper and lower speaker terminals on your speakers.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Sep 2004
    Location
    Xanadu
    Posts
    180

    Default

    Hello Stringz,
    DB is on to something, those speakers can be bi-wired or bi-amped. But if you're not doing that you would want to use a short piece of speaker wire to connect the upper and lower binding posts together. Or, you could go ahead and bi-wire the speakers and make a modest improvement to mid range clarity? Either way will get all of the speaker working fine.
    Jed

  4. #4

    Member Sales Rating: (58)

    Join Date
    Feb 2003
    Location
    6 Underground
    Posts
    25,306

    Default

    You should look in the box for the jumpers that are inserted between the binding posts. They will be a shiny brass color. If you cannot find them...

    polkcs@polkaudio.com
    9am - 6pm, M-F, EST (USA)
    800-377-7655 toll free phone
    410-764-5470 fax

    In regards to bi-wiring, don't spend money on something you don't need right now.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Posts
    2

    Default

    thanks a lot guys, i used the jumper and it works fine :)

    your replies were all very appreciated!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Hooking Up the Polk Monitor 50s
    By cwalker05 in forum Basic Hookup/Wiring Questions
    Replies: 5
    Last Post: 12-30-2007, 04:21 PM
  2. Trouble with Monitor 70s
    By mimir in forum Troubleshooting
    Replies: 14
    Last Post: 06-11-2007, 07:36 AM
  3. Monitor 5JR trouble
    By elarocque in forum Troubleshooting
    Replies: 3
    Last Post: 03-25-2007, 02:08 PM
  4. Trouble with Pre-Amp; Nad 712
    By AndyGwis in forum Electronics
    Replies: 26
    Last Post: 01-24-2007, 05:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts