Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Posts
    138

    Default Tweeter popping sound, distorting sort of?

    So i have Monitor 30s and PSW12, with an Onkyo sr304. So i was listening to some CDs today and noticed that the speakers/tweeter? seem to pop on one 311 song with just a guitar intro, It sounds like that pop you get when you turn up the volume with the remote control while music is playing.

    And also on some other tracks it almost sounds like the highs are slightly distorted. Not every CD does this, but it's not only one CD I've heard this on. When tweeters blow or are damaged is it easy to tell?

    I've referenced the strange noises with the same CDs on my KRK recording monitors (i do basement studio stuff) and none of it was present. Any ideas on what it could be, I've never cranked the Monitor 30's up to a level where you could hear them distorting, all though i do listen to them loudly on occasion, any ideas?

  2. #2

    Member Sales Rating: (26)

    Join Date
    Oct 2006
    Location
    The tube lair in Charlotte, NC
    Posts
    11,323

    Default

    Have you determined that it's not the Onkyo?
    In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

    The best way to enjoy digital music reproduction is to never listen to good analogue reproduction.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Posts
    138

    Default

    good call, i hooked up the right channel (the guitar track is mostly the right side) up to my older and small Polk RM series surround/front speaker, and it had the same pop, and I'm almost sure it's not the CD. So tomorrow I will try my dads Yamaha receiver. If it is the Onkyo I'm going to be pissed cause I wanted to get the 'high end-ish" A-9555, and now I'm not to sure of Onkyo.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Posts
    138

    Default

    Today I tried my dads older yamaha RX395 and no problems, but now I'm wondering if it could have been in the optical cable i used to hook up the SR304 to my Xbox 360
    (i use it as a CD player, and stream stuff off my computer, I tend to rip CDs as wavs, so it wasn't an MP3 quality issue) But clearly the Yamaha has more power even if it has a lower power rating, and sounds much better anway.

    Strange, I wonder if the Onkyo is broken, or just sorta crappy, or if maybe even its the xbox?

  5. #5

    Member Sales Rating: (0)

    Join Date
    Aug 2005
    Location
    leeds uk
    Posts
    337

    Default

    just because i simply dislike xbox360's any time anything slightly crappy is going on i would automatically blame it on the 360/360 compatibleness,try reducing the playback volume on the xbox ,coz when ive had ours connected up to my avr i noticed it seemed to be a bit louder than my other devices (seemed to be). This may identify if the onkyo doesn’t like large volume inputs or is just the 360 been crap.....again.
    ELECTRONICS
    arcam cd93
    linn wakonda
    MC2 MC450
    Teac ud h01 DAC


    SPEAKERS
    Tannoy DC6 t se .

  6. #6

    Member Sales Rating: (44)

    Join Date
    Jul 2007
    Location
    INDIANA
    Posts
    2,868

    Default

    I kind of skimmed through the thread and noticed you mentioned the optical cable. I would defiantly try a different one or try analog. I had a optical cable that was just kinked and it was doing the exact same thing you are talking about. It took the longest time to figure it out. I don't use optical anymore.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Subwoofer popping sound
    By Early B. in forum Subwoofer Hookup & Bass Management
    Replies: 5
    Last Post: 11-16-2007, 12:22 PM
  2. my tweeter is popping
    By danger boy in forum Speakers
    Replies: 0
    Last Post: 05-04-2004, 06:40 PM
  3. PSW 404 popping banging sound
    By WopOnTour in forum Troubleshooting
    Replies: 5
    Last Post: 10-25-2003, 10:45 PM
  4. Popping Sound In PSW450
    By rsmith4321 in forum Troubleshooting
    Replies: 46
    Last Post: 09-07-2002, 12:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts