Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 16 of 16
  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default M&K - Subwoofer Driver Problems

    Yeah, today has been a bad day...newayz...the forward firing driver on my m&k has either blown, or a wire has come loose, its like it playing the sound, but only half way --- like its moving and is making a sound, but not the right sound, like a ruffled sound -- i know M&K drivers cost 250 dollars each, and i hope its not the problems because i will go a while without a subwoofer if thats a case, me and my dad think its either a loose contact or a loose wire..and this is where mantis and liv4fam's knowlage is good...lol...newayz can someone help me out here...
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  2. #2

    Member Sales Rating: (40)

    Join Date
    Jul 2001
    Location
    North Texas
    Posts
    18,401

    Default

    Remove the driver, see if your theory is correct. If you press lightly and evenly on the driver, do you hear a 'rubbing' sound?

    Cheers,
    Russ
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.

  3. #3

    Member Sales Rating: (1)

    Join Date
    May 2002
    Location
    Funny Farm"no doubt there"
    Posts
    5,329

    Talking

    ya got a hammer?


  4. #4

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default

    Originally posted by RuSsMaN
    If you press lightly and evenly on the driver, do you hear a 'rubbing' sound?
    when i press on the driver while it is still in the cabnet.....no rubbing sound at all...what does this mean????
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  5. #5

    Member Sales Rating: (40)

    Join Date
    Jul 2001
    Location
    North Texas
    Posts
    18,401

    Default

    Originally posted by MxStYlEpOlKmAn


    when i press on the driver while it is still in the cabnet.....no rubbing sound at all...what does this mean????
    That more than likely the voice-coil is ok. Remove the driver.

    Cheers,
    Russ
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.

  6. #6

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default ....

    ill let my dad do that....lol.....but thanks for that incentive...lol....
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  7. #7

    Member Sales Rating: (40)

    Join Date
    Jul 2001
    Location
    North Texas
    Posts
    18,401

    Default

    You can do it, just do it slowly and carefully. If the is front driver, lay the sub on its back first.

    Cheers,
    Russ
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.

  8. #8

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    'burb of Detroit
    Posts
    3,042

    Default

    Did you say that you bought if off your dad and that he had 2. Hurry and swap it out before he gets home.
    Make it Funky! :)

  9. #9

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default ....

    lol...thatd be a good idea...but he dont live here.....and i dont think carrying a subwoofer about 13 miles really would help it...lol...but we're gonna take it to a buddy of ours tommorow see what he can do wit it....
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  10. #10

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default ...

    well its official...the driver is blown..its been hand grenaded.....NEWAYZ it costs 200 bucks.....or more to replace...the cause, a bad signal from my yammer receiver, which has really made me go against yamaha...atleast their lower lines..because my dad has ran this thing at 110 db for 14 years, and has had no problems, he runs his wit adcoms and yamaha...newayz i got a question, what do yall think of using the yamaha for a pre and a outlaw audio 5 channel for the amp?
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  11. #11

    Member Sales Rating: (1)

    Join Date
    Mar 2002
    Location
    New York
    Posts
    3,779

    Default Re: ...

    Originally posted by MxStYlEpOlKmAn
    well its official...the driver is blown..my dad has ran this thing at 110 db for 14 years, and has had no problems...
    Is it possible that running the sub at 110 dB for 14 years just might have contributed to a blown driver?

    Also, how loud were you running it just before it blew?

    When you say the driver blew because of a "bad signal" from the Yamaha receiver, what exactly do you mean by that?

    Are you running an LFE pre-out signal to the M&K? If so, what was the electronic sub volume set at on the Yamaha? What is the total range of control for the sub volume (e.g., -10 to +10) on the Yamaha?

    Doc
    "What we do in life echoes in eternity"

    Ed Mullen (emullen@svsound.com)
    Director - Technology and Customer Relations
    Specialty Technologies
    SVSound

  12. #12

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default

    Is it possible that running the sub at 110 dB for 14 years just might have contributed to a blown driver?

    Also, how loud were you running it just before it blew?

    When you say the driver blew because of a "bad signal" from the Yamaha receiver, what exactly do you mean by that?

    Are you running an LFE pre-out signal to the M&K? If so, what was the electronic sub volume set at on the Yamaha? What is the total range of control for the sub volume (e.g., -10 to +10) on the Yamaha? --

    welp...thats what i think...i think it just gave out...because i think if one driver blew...the second one would too...so i think both theories are correct....

    i was running them around -33.00 on the receiver out of 100

    its running by a subwoofer cable, lfe out to the receiver.....

    my dad's theory is "it went past its able volume limits, started to send a distorted signal to the speakers -- which were sounding normally fine at the time for a thought -- and sent a distorted signal to the sub...."

    well the sub is only turned up to half way on the sub, and 0 db flat on the receiver, crossover at 60 hz, its set up correctly.....i think the driver just gave out....but i guess both theories are correct...

    but it just dont make sense that at -33.0 that the speaker would blow...thats about 40 db lower than my dads volume...but thats besides the point

    i have been wanting to find out how good m&k's new drivers are newayz...and if they are better i will go ahead and get two and when the bottum driver blows....ill have it ready to go...and im probally going to get the old one reconed just in case...unless it cost over 100 dollars to get done....NEWAYZ! i hope that answers alot of questions...
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  13. #13

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default ......

    also i really dont think him playing it that loud did it..i think the driver just had all it could take...the setup my dad has, yamaha dsp, 3 - 2 channel adcom amps, a huge yamaha amp....and the adcoms has lights that blink when they are at their max level of volume, and hes never over played them, and has alwayz played them half way...he had two also...so the signal has alwayz been split in two......

    the subwoofer also changed enviorments - musically, my dad listens to country....i listen to korn, eminem, and all those freaks....lol....and they sometimes are recording really bad...so i dunno...newayz....tell me what yall think...newayz....thanks for all suggestions and help
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

  14. #14

    Member Sales Rating: (14)

    Join Date
    Jul 2001
    Location
    Pa
    Posts
    13,543

    Default

    dude,
    I called in a friend that carries M&K,he said you should be able to contact them direct,E mail or by Phone.Hang in there,they will respond.

    Good Luck!!
    Dan
    My personal quest is to save to world of bad audio, one thread at a time.

  15. #15

    Member Sales Rating: (1)

    Join Date
    Mar 2002
    Location
    New York
    Posts
    3,779

    Default

    With a "0" setting for the sub volume on the Yammy, I highly doubt it was sending the sub a "bad signal".

    If you crank up the sub volume to +10 (or whatever the limit is), then the tiny pre-amp that send the LFE signal can begin to experience signal compression problems, much like a real amp clipping.

    My guess? It's not the Yammy - it's just years of pretty extreme duty catching up to the drivers. I'm sure Korn and Eminem didn't help any either.

    BTW, 1/2 volume at the sub amp does not necessarily mean it's a "safe" setting. The combination of the receiver sub setting, and the sub amp volume setting are ultimately irrelevant - what really matters is how much SPL the sub is belting out with source material at any given Master Volume setting.

    Scott Goldsmith destroyed his SVS 20-39 PC+ with the sub amp volume set at less than half. Why? He was majorly overcalibrated.

    Have you calibrated the system with a decent SPL meter and test tones or an Avia or VE disc?

    Doc
    "What we do in life echoes in eternity"

    Ed Mullen (emullen@svsound.com)
    Director - Technology and Customer Relations
    Specialty Technologies
    SVSound

  16. #16

    Member Sales Rating: (0)

    Join Date
    May 2002
    Location
    Vr3MxStyler2k3
    Posts
    2,112

    Default ..

    Thanks for the help, I dont know what a SPL meter is. LoL. Well, everything on my receiver is set to 0, being played around 70 db wit the sub at half volume, all bass directed to the sub. The thing about it was, I think it just gave out. I mean over 14 year and then it switching enviorments of bad recordings from Eminem and uncontrollable bass of Korn! LOL! Eminem recording are set like this to those of you wondering why it sucks: 5+ gain in Bass, 2+ gain in Treble, and a Distorted sound feild - minor is set while he is recording, that is why it sucks so bad! Anywayz, thanks for all the help and advice!

    Mantis - I got in touch with M&K, their new drivers are $82.50 for one. They also got free shipping, so thats cool. Well if the new driver is night and day to the old one, I will probally upgrade the down firing driver also. I will see, anyways thank you for your help also!

    Russman - LoL, Well my Dad took out the driver. He had a good idea of plugging it directly into the receiver and playing music through it to see if it would blow. Well, around 90 DB the music really was starting to get audible, and all the sudden POPS AND BANGS were soaring everywhere...LOL! Anywayz, Thanks for your help also!

    Alright, I'm bored and If I missed anyone else that helped me....THANK YOU! LOL! Now i gotta wait 9 days for a effin driver!!! HAAAAAAAAAAAAAAAAAAAAAA!

    -MX-
    Damn you all, damn you all to hell.......
    I promised myself
    No more speakers. None. Nada. And then you posted this!!!!
    Damn you all! - ATC

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts