Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (0)

    Join Date
    Mar 2008
    Posts
    2

    Default DB104's......need help.

    Im a toal noob when it comes to subs but I think i'v leanered alot, unfortuneaetly mostly through mistakes. I had two db10's in a box that wasnt sealed too good and i think that was bad for them, they were in there for a while. One of the connection wires broke off to one of the subs so it wasnt playing, but i guess i didnt notice? I resodered everything but it wont even play now. I made a new box, sealed very tight. I got one sunning now through a kicker 400.1 . I was suggested to do a ohm reading to see if this sub is damaged or not because to me it still sounds muddy.

    Using a multi meter i never got a constant 4 ohm reading? Im new to electrical stuff so maybe im measuring it wrong but it was all over the place from like 1 to 40 which doesnt make sense.

    Im so lost on how to make them sound correct. Iv already gone through a month of making sure all other wriing from headunit is correct, and it is, so its down to the subs and box. Help me out please!

  2. #2

    Member Sales Rating: (15)

    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    560

    Default

    Welcome to CP. You'll probably get a much better response if you post your questions in the Car Audio section ...

    http://www.polkaudio.com/forums/forumdisplay.php?f=5
    My HT
    HDTV: Panasonic PT-61LCX65 61" Rear Proj. LCD
    AVR: Harman Kardon AVR 235
    Video: 80GB PS3, Toshiba HD-XA1 HD DVD
    Fronts: Polk Audio RTi8
    Center: Polk Audio CSi3
    Amp: Emotiva LPA-1
    Surrounds: Polk Audio R150
    Sub: HSU STF-3


    The only true barrier to knowledge is the assumption that you already have it. - C.H. Dodd

  3. #3
    Polk Customer Service
    Member Sales Rating: (0)

    Join Date
    Jul 2004
    Location
    Polk Audio HQ
    Posts
    556

    Default

    I'll move it.
    -Eric
    -Polk Audio

  4. #4

    Member Sales Rating: (0)

    Join Date
    Mar 2008
    Posts
    2

    Default

    oops, my bad. didnt notice that. thanks for moving it!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. okay... my temp amp for the DB104's
    By nadams in forum Car Audio & Electronics
    Replies: 10
    Last Post: 01-05-2006, 02:53 PM
  2. The DB104's are back on sale!
    By nadams in forum Car Audio & Electronics
    Replies: 21
    Last Post: 12-02-2005, 05:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts