Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 8 of 8
  1. #1

    Member Sales Rating: (0)

    Join Date
    Nov 2002
    Location
    Australia
    Posts
    2

    Question Unwanted Radio coming through Subwoofer

    Hi,

    I have this annoying problem where I can hear my local radio
    station being picked up through my subwoofer. This occurs
    even when I have my amp turned off or set to DVD. The subwoofer is a PSW250 connected via CableTalk Talk 3.1 to a
    Yamaha RXV530. The subwoofer is positioned about 2 metres
    away from the amp. Does anybody have any suggestions on how I can alleviate this problem?

    cheers,
    Simon

  2. #2

    Member Sales Rating: (14)

    Join Date
    Jul 2001
    Location
    Pa
    Posts
    13,543

    Default

    Sound like your using your interconnect as an antenna.
    Swap out the cable for a higher quality shielded cable.Monster makes em as well as aot of good quality cable companies.You problem allies there I believe my friend
    Dan
    My personal quest is to save to world of bad audio, one thread at a time.

  3. #3

    Member Sales Rating: (1)

    Join Date
    Mar 2002
    Location
    West Des Moines, IA
    Posts
    3,221

    Default

    Do they have Monster cable in Australia? haha

  4. #4

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Posts
    3,292

    Default

    connected via CableTalk Talk 3.1
    Not sure what this is - I agree try some good shielded cable.
    Monster Bass Cable.
    PS3 and HD Front Projection, life is good. Too bad Blu-Ray and the PS3 are already obsolete.....

  5. #5

    Member Sales Rating: (11)

    Join Date
    Jul 2001
    Location
    Spokane, Washington
    Posts
    15,835

    Default

    In Australia look for IXOS cables.. very similar to monster.. i used to have the same problem with my sub.. when my neighbor would use his ham radio.. got a 3 meter IXOS sub cable.. no more noisey neighbor
    PolkFest 2012, who's going>?
    Vancouver, Canada Sept 30th, 2012 - Madonna concert

  6. #6

    Member Sales Rating: (14)

    Join Date
    Jul 2001
    Location
    Pa
    Posts
    13,543

    Default

    SO did we cahnge out the cable and now the sub isn't a radio anymore???I 'd like to know.
    Dan
    My personal quest is to save to world of bad audio, one thread at a time.

  7. #7

    Member Sales Rating: (0)

    Join Date
    Nov 2002
    Location
    Australia
    Posts
    2

    Default

    Thanks for your replies guys. I did a few experiments to confirm
    if the cable was the culprit and it indeed looks like it.

    - I disconnected the speaker cables from the amp to the subwoofer. Still happening.

    - I disconnected the cables from the subwoofer to the satellite speakers as well. No radio.

    - I then used a different cable to hook up the subwoofer to the amp. This time I just used a Y-cable interconnect from the subwoofer output on the amp to the line inputs on the subwoofer. Could still hear the radio.

    An interesting note. If I turn the subwoofer off via the switch at the back I can still hear the radio through the speaker! It only stops once I pull the power cable out of the power point.

    Looks like my only option is to swap out the speaker cable which I'm not too cool about. I only bought it a couple of weeks ago and it cost me a packet!

    Does speaker cable come shielded? I had a look on the web sites and they don't seem to have much info.

  8. #8

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    Sitting pretty in AZ
    Posts
    1,152

    Default

    An interesting note. If I turn the subwoofer off via the switch at the back I can still hear the radio through the speaker! It only stops once I pull the power cable out of the power point.
    almost sounds as if you could use something like the monster power, where it actually cleans up the electrical noise that comes through ???
    just a thought
    Speakers:
    Definitive BP7001sc mains
    Definitive C/L/R 3000 center
    Polk RT800i's rears
    Definitive supercube I Sub
    Audio:
    Onkyo TX-NR3010
    Adcom GFA 7500
    OPPO BDP-103 CD, SACD, DVD-A
    Video:
    Panasonic TC-P65ZT60
    OPPO BDP-103 Bluray
    Directv x's 2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts