Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Polk-a-dweeb
    Member Sales Rating: (0)

    Join Date
    Apr 2002
    Location
    Colorado
    Posts
    5,976

    Default Sub Trouble Shooting

    Had a power outage a few days ago and when the power was restored my Sunfire TrueSub EQ was humming like mad.

    Disconnected from power, reconnected....still humms.
    Shut it down again, disconnected Y-connector (no input at this point), re-applied power...still hums.
    Ran it through an EQ cycle...still hums.

    It's out of warranty so I'm going to have to pay to get the ****er repaired by Sunfire.

    Anything else to check before I box it up?

    FWIW, the fuse is good...whoopie!
    9/11 - WE WILL NEVER FORGET!! (<---<<click)
    2005-06 Club Polk Football Pool Champion!! :D

  2. #2

    Member Sales Rating: (58)

    Join Date
    Feb 2003
    Location
    6 Underground
    Posts
    25,306

    Default

    Get it ready for shipping.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Trouble Shooting LSiC One speaker no sound
    By mwaarna in forum Troubleshooting
    Replies: 6
    Last Post: 02-16-2007, 04:14 PM
  2. Trouble shooting RM1300
    By joro514 in forum Troubleshooting
    Replies: 1
    Last Post: 04-05-2005, 10:32 AM
  3. Shooting at Best Buy
    By TheReaper in forum The Clubhouse
    Replies: 6
    Last Post: 02-14-2005, 12:27 PM
  4. Trouble Shooting Subwoofer Help??
    By Keane in forum Troubleshooting
    Replies: 1
    Last Post: 02-12-2005, 06:41 PM
  5. Did anyone see this shooting today...
    By avelanchefan in forum The Clubhouse
    Replies: 22
    Last Post: 11-03-2003, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts