Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 12 of 12
  1. #1

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    24

    Default 15" Polk Momo Mm2154dvc hook up

    i have a jl audio e1200 200W@2ohms 125W@4ohms and a 15" MM2154DVC...the amp has a 8 awg wire running it, theres two brachets on the speaker so that you can make it changable from 4 ohms to 2 ohms,how do i make the speaker 2ohms?i tried but it makes my amp hott and the speaker starts to cut out after awhile wut am i doing wron?

  2. #2

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,827

    Default

    To get a 2 ohm load, youd run the + and - from each voice coil straight to the + and - of the amp.

    Not sure why the amp is getting hot. Even if you wired it wrong the most you can get out of that sub is a 2 ohm load which that amp can do.

    2 things, are you running 8 gauge ground wire as well? If so, is it tightly secured? Also, how high is the gain set? Shouldnt be more than halfway at most.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  3. #3

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    24

    Default

    the ground wire is a 8 gauge as well but it's a different brand would that mess with it? my ground wire connected to the amp is kinda loose cuz the bolt is striped..........

    yea the gain is set over half n my hz is set half should i try it the other way set the gain to half and the hz over half?

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,827

    Default

    That could be the problem. Turn the gain down to about the 11 o'clock position and get a proper bolt for the ground so you get a nice tight fit and see if that fixes it.

    The Hz is the low pass filter. Set it at 80 for now and see how it goes.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  5. #5

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    24

    Default

    My ground bolt is completly stripped how would i get a strip bolt out.....

  6. #6

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    Laker City (LA), CA
    Posts
    1,071

    Default

    gator tool?
    2013 Toyota Prius
    Audible Physics 3 Way: H6MB, AR3-A, AR2.0
    Image Dynamics iDMax 12" D2v4
    (2) Alpine PDX-V9 Bridged, Alpine PDX-M12 (500w Mid-Bass, 200w Mid, 200w Tweet, 1200w Sub)
    Mosconi 6to8 v8

  7. #7

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    24

    Default

    what kind of amp would yo recommend for the 15? it's 400 watt rms and 800 watt max i want an amp that will kick me in the chest by the bass hits and one that shakes my whole body and eyeballs...the 1 i got now really doesnt do that at all.....

  8. #8

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    Laker City (LA), CA
    Posts
    1,071

    Default

    600 watt class D amp should do it
    2013 Toyota Prius
    Audible Physics 3 Way: H6MB, AR3-A, AR2.0
    Image Dynamics iDMax 12" D2v4
    (2) Alpine PDX-V9 Bridged, Alpine PDX-M12 (500w Mid-Bass, 200w Mid, 200w Tweet, 1200w Sub)
    Mosconi 6to8 v8

  9. #9

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,827

    Default

    Ignore the peak or max rating. Meaningless.

    Get you something thatll make 400+ RMS at 2 ohms mono.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  10. #10

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    24

    Default

    you think if i got a jl audio 500/1 it would be good for my 15?
    It runs at 500 wat rms @ 1.5-4 ohms
    is jl audio a good brand for power refrences, what would be the best amp for power refrence. I bought this off a friend and the way he had it you could hear from 3-4 blocks away so i know it gots the power?

  11. #11

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,827

    Default

    A JL 500/1 would be just right.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  12. #12

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    24

    Default Here's The Most Craziest Thing That Happens And Need Answers?

    so i got a kenwood KAC-9125D it runs at 500wx1@4 ohms 900wx1@2ohms 1800w max. theres a + + - - if i hook both up seperate will the 1800w apply or will it split the power in two?
    also i had it hooked up blew the battery fuse, changed the fuse turn car on and it workd. turned off, turn key back now it don't work...HERE'S THE MOST CRAZIEST THING THAT HAPPENS AND NEED ANSWERS?
    i put a screwdriver to the gnd screw try to unscrew it and touch the amp with the screwdriver.....light comes on it works when i take it off it doesnt?when i lean the screwdriver on the amp when touching gnd screw on amp it work, when i dont lean it comes off? wtf is goin on, hooked up other amps they work just fine, need a bigger wire i got a 8awg(500w rms) running to it?do i have a short in a wire?is the amp i protect mode. Hooked up to another vehicle works fine?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. 15" Polk Momo Mm2154dvc hook up
    By joker187 in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 04-08-2008, 10:34 AM
  2. 15" Polk Momo Mm2154dvc
    By joker187 in forum Troubleshooting
    Replies: 1
    Last Post: 04-07-2008, 03:14 PM
  3. Replies: 0
    Last Post: 09-26-2007, 01:47 PM
  4. Brand New Polk/MOMO comps f/s 5.25" & 6.5"
    By 96montecarlo in forum Flea Market
    Replies: 1
    Last Post: 05-31-2005, 03:11 PM
  5. 12"Infinity Perfect Kappa 12vq vs Polk momo 12" mm124
    By popnfresh in forum Car Audio & Electronics
    Replies: 25
    Last Post: 04-18-2004, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts