Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 5 of 5

Thread: PSW 10 Dead

  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2008
    Posts
    3

    Thumbs down PSW 10 Dead

    Yesterday when I started my system, the subwoofer failed to turn on.
    There is no power light. I checked for line voltage, it was 119VAC, and verified that I had a sub line output from my receiver with an oscilloscope. The sub is
    about 3 years old. Is their an internal fuse to check? Any other suggestions
    would be welcome.

  2. #2

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,277

    Default

    You've got an oscilloscope and a VOM, so you must know a few things about electronics. Why not open it up and take a look around.
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  3. #3

    Member Sales Rating: (0)

    Join Date
    May 2008
    Posts
    3

    Default

    I was just seconds from doing that, but realized if I could find my receipt It might still be under warranty. I was hoping someone has had a similar problem and maybe had some pointers while I procrastinated opening the box.

    I may do it later as I still can't find the receipt.

    Thanx

  4. #4

    Member Sales Rating: (2)

    Join Date
    Aug 2003
    Location
    BC, Canada
    Posts
    2,904

    Default

    This problem has showed up before. Just give Polk customer service a call and they'll sort it all out for you. They're pretty awesome when it comes to providing great support for their products. You'll probably have to pull the amp (about 6 screws and a couple connectors - quite easy) and ship it to them.

    polkcs@polkaudio.com
    800-377-7655, Option 1 toll free
    410-764-5470 fax
    International +1-410-358-3600

    Hours Of Operation
    9am - 5:30pm, M-F, EST (USA)

  5. #5

    Member Sales Rating: (0)

    Join Date
    May 2008
    Posts
    3

    Default Thanks

    Quote Originally Posted by michael_w View Post
    This problem has showed up before. Just give Polk customer service a call and they'll sort it all out for you. They're pretty awesome when it comes to providing great support for their products. You'll probably have to pull the amp (about 6 screws and a couple connectors - quite easy) and ship it to them.

    polkcs@polkaudio.com
    800-377-7655, Option 1 toll free
    410-764-5470 fax
    International +1-410-358-3600

    Hours Of Operation
    9am - 5:30pm, M-F, EST (USA)
    I called them today and they were extremely helpful. They would look
    at it and consider a warranty repair without my reciept.

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. AVR Dead?
    By bionicmushroom in forum Electronics
    Replies: 10
    Last Post: 05-11-2007, 11:37 PM
  2. Is hi fi dead?
    By NeilGabriel in forum 2 Channel Audio
    Replies: 49
    Last Post: 04-19-2007, 06:20 PM
  3. 22 Dead at VT
    By Demiurge in forum The Clubhouse
    Replies: 137
    Last Post: 04-19-2007, 10:20 AM
  4. SVS is dead...
    By Grimster74 in forum Subwoofer Hookup & Bass Management
    Replies: 9
    Last Post: 09-28-2006, 08:36 AM
  5. Is it dead?
    By sntnsupermen131 in forum Car Audio & Electronics
    Replies: 87
    Last Post: 07-22-2003, 12:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts