Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (16)

    Join Date
    Jan 2007
    Location
    eastern Pa
    Posts
    536

    Default You got to be kidding me

    Well i picked up a new used stand today and after the change
    over my GFA-555 dosen't seem to want to work.
    It powers on but thats it. When i had it out i flicked the mono
    switch a few times not sure why i guess because i never did
    before.
    Looks like i will start with the fuses. But my hats off to the
    GFA-5300 it kicks ass so it looks like i will be pulling the F/S
    add on the 5300 and keep it.
    jerry
    Attached Thumbnails Attached Thumbnails Click image for larger version

Name:	stand 001.jpg‎
Views:	94
Size:	190.3 KB
ID:	34166   Click image for larger version

Name:	stand 002.jpg‎
Views:	83
Size:	180.2 KB
ID:	34167  
    Main- GTP-500II,GDC-600,GFA-555II and energy C-500s
    Basement-Audiosource pre/tuner,GFA-545,Onkyo
    DX-1400 and RTI10s
    Garage-GTP-450,onkyo M-282 and R50s with RTi55
    drivers and X-overs.
    My baby 18' V-king Mod VP with a merc 2.4 BP.
    KTM 620 Supermoto

  2. #2

    Member Sales Rating: (1)

    Join Date
    Apr 2007
    Location
    winston-salem, nc
    Posts
    267

    Default

    jerry, if all you did was unhook it, move it, and rehook it, it has to be something simple. i dont know how that switch works, but some tuner cleaner might fix all of your woes. i have had numerous problems with dirty switches/pots/contacts on various gear in my life. here is hoping.

    BTW, i just got through doing just that on this, lol:


    it took a few minutes (yeah, a few), but it works great! no scratchiness or dropouts at all.
    a
    gear list:
    1 down, 4 up....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. T-Amp Gen 2 Amplifier - Are you kidding me?
    By nodeuces in forum Electronics
    Replies: 6
    Last Post: 01-31-2008, 12:57 PM
  2. You've got to be kidding me!!!
    By JSHRN in forum The Clubhouse
    Replies: 2
    Last Post: 11-16-2007, 11:05 PM
  3. Replies: 7
    Last Post: 12-28-2005, 05:39 PM
  4. You've got to be effin kidding me!?
    By PolkThug in forum The Clubhouse
    Replies: 3
    Last Post: 05-09-2005, 04:22 PM
  5. You gotta be kidding, right?
    By Pauly in forum The Clubhouse
    Replies: 0
    Last Post: 10-24-2003, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts