Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2

Thread: PA500.4 issues

  1. #1

    Member Sales Rating: (0)

    Join Date
    Jul 2008
    Posts
    1

    Question PA500.4 issues

    After installing a PA500.4 amplifier I have an excessive amount of electrical interference(high-pitched squealing sound) coming through the speakers, especially when the car is running. I know this is interference from the car's electrical system, but I'm not quite sure how to fix the problem.
    Last edited by hal9000k; 07-30-2008 at 01:25 AM. Reason: Solved original problem, found new problem.

  2. #2

    Member Sales Rating: (6)

    Join Date
    Jan 2008
    Location
    Austin Tx
    Posts
    1,336

    Default

    car forum is down a bit farther:D

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. B&K Issues
    By Meechsterlee in forum Electronics
    Replies: 12
    Last Post: 09-23-2007, 09:11 AM
  2. IE issues
    By MrNightly in forum The Clubhouse
    Replies: 24
    Last Post: 08-27-2007, 02:29 PM
  3. Ohm Issues
    By Meechsterlee in forum Car Audio & Electronics
    Replies: 8
    Last Post: 04-16-2007, 11:10 AM
  4. RT3 Issues
    By Cerrig in forum Speakers
    Replies: 3
    Last Post: 06-15-2006, 12:13 AM
  5. Possible SPL Issues
    By demosthenis in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 05-17-2006, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts