Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 23 of 23
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default New PSW1000 dead in 1 minute

    New PSW1000 dead in 1 minute? I Have 2 of these and the older one works fine, but the new one had a short life. It still powers on and lights up green when a signal is present but no output? I tried all the switches and still no sound. Am I missing something?
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  2. #2

    Member Sales Rating: (11)

    Join Date
    Jul 2001
    Location
    Spokane, Washington
    Posts
    15,835

    Default

    does it have a fuse? if so.. pull it and check to see if it blew when you turned it on.. it's possible that it did.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Quote Originally Posted by danger boy View Post
    does it have a fuse? if so.. pull it and check to see if it blew when you turned it on.. it's possible that it did.
    Fuse is OK, the unit still has the power indicator light on.
    Last edited by BLACKHAMMERJAMM; 07-17-2008 at 04:59 AM.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  4. #4

    Member Sales Rating: (11)

    Join Date
    Apr 2004
    Location
    Chicagoland
    Posts
    2,367

    Default

    Were you driving it hard? Its possible (though improbable) that a connector that was working loose in transit finally came loose - most likely the connector that hooks the amp to the subs. If you know what you are doing, you can remove the plate amp and take a look inside.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Quote Originally Posted by anonymouse View Post
    Were you driving it hard? Its possible (though improbable) that a connector that was working loose in transit finally came loose - most likely the connector that hooks the amp to the subs. If you know what you are doing, you can remove the plate amp and take a look inside.
    Thats possible.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  6. #6
    Audiophile
    Member Sales Rating: (30)

    Join Date
    Mar 2006
    Location
    Seattle
    Posts
    11,185

    Default

    I would poke around inside as mentioned before and see if it is something simple. Did you say that the sub is new and had only been on for 1 minute when it stopped working?

  7. #7

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Quote Originally Posted by zingo View Post
    I would poke around inside as mentioned before and see if it is something simple. Did you say that the sub is new and had only been on for 1 minute when it stopped working?
    1 minute, yes. Opened it up and checked all the connections. Nothing is loose or unconnected. The speakers do hum when I remove the RCA cable. I think I will just send it back.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  8. #8

    Member Sales Rating: (26)

    Join Date
    Oct 2006
    Location
    The tube lair in Charlotte, NC
    Posts
    11,323

    Default Test.

    Mr. BHJ, have you tried to hook it up to a known working RCA out that works [hookup while unplugged] that leads from one of your sources? [CDP, DVD, LP, etc....]

    If you have not, test with the volume ALL of the way down on the sub and slowly work your volume up on the sub. If you have sound coming from the PSW1000, then it is not the sub. Try this, if you will and then get back to us please.
    In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

    The best way to enjoy digital music reproduction is to never listen to good analogue reproduction.

  9. #9

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Quote Originally Posted by treitz3 View Post
    Mr. BHJ, have you tried to hook it up to a known working RCA out that works [hookup while unplugged] that leads from one of your sources? [CDP, DVD, LP, etc....]

    If you have not, test with the volume ALL of the way down on the sub and slowly work your volume up on the sub. If you have sound coming from the PSW1000, then it is not the sub. Try this, if you will and then get back to us please.

    I have 2 PSW1000's, so I tested the broken one by using the RCA out that is normally connected to the working one. I tried the volume thing and just about all the switches. I still could be missing a test or 2, so any suggestions are much appreciated.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  10. #10

    Member Sales Rating: (26)

    Join Date
    Oct 2006
    Location
    The tube lair in Charlotte, NC
    Posts
    11,323

    Default

    Edited.
    In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

    The best way to enjoy digital music reproduction is to never listen to good analogue reproduction.

  11. #11

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Returned to Polk for Replacement. I will update return-replacement status and turnaround time. Hope it doesn't take too long.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  12. #12

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Location
    Silicon Valley
    Posts
    6,139

    Default

    Quote Originally Posted by BLACKHAMMERJAMM View Post
    Returned to Polk for Replacement. I will update return-replacement status and turnaround time. Hope it doesn't take too long.

    How much did it cost to ship that heavy beast?

  13. #13

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Quote Originally Posted by BlueFox View Post
    How much did it cost to ship that heavy beast?
    About $200 from my pocket.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  14. #14

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    It's now at the Polk service center...Just waiting for someone to open it up and check it out.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  15. #15

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Posts
    116

    Default Sony Blu-Ray Players.

    This is not about your PSW1000 subwoofer, but about your Sony BDP-2000ES.

    I have a BDP-S1 instead, and noticed that if I am watching a PCM source like uncompressed PCM, then it sounds louder and better if I put the audio setting of a blu-ray player at PCM. Likewise, if I am watching either a Dolby Digital, DTS, DTS MA, or Dolby TrueHD sources, then it sounds louder and better if I put the audio setting at Auto (sending out audio codecs as bitstreams for a receiver or a pre-amplifier to do the decoding instead). Have you noticed that difference or is it just me? It is combersome to switch the setting back and forth depending on the sources, but I do seem to notice the difference in sound qualities between the settings and the audio sources.

  16. #16

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Quote Originally Posted by garnier View Post
    This is not about your PSW1000 subwoofer, but about your Sony BDP-2000ES.

    I have a BDP-S1 instead, and noticed that if I am watching a PCM source like uncompressed PCM, then it sounds louder and better if I put the audio setting of a blu-ray player at PCM. Likewise, if I am watching either a Dolby Digital, DTS, DTS MA, or Dolby TrueHD sources, then it sounds louder and better if I put the audio setting at Auto (sending out audio codecs as bitstreams for a receiver or a pre-amplifier to do the decoding instead). Have you noticed that difference or is it just me? It is combersome to switch the setting back and forth depending on the sources, but I do seem to notice the difference in sound qualities between the settings and the audio sources.
    I will check later tonight, I think I'm set on auto?
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  17. #17

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    It sat for one day and then was fixed. Color didn't match the rest of my other speakers so they looked for a new one to match the newer production PSW1000's. tomorrow Polk service will ship me back a new sub. So far I call this as great customer service.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  18. #18

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Location
    Silicon Valley
    Posts
    6,139

    Default

    Quote Originally Posted by BLACKHAMMERJAMM View Post
    It sat for one day and then was fixed. Color didn't match the rest of my other speakers so they looked for a new one to match the newer production PSW1000's. tomorrow Polk service will ship me back a new sub. So far I call this as great customer service.
    Maybe there will be 2 one hundred dollar bills in the return box to cover your shipping. :)

    Good luck. I love my LSi15s and PSW1000.

  19. #19

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    No $200 in the box with the new PSW1000.... Well at lease this one makes noise, but the damn volume control is broke... The people at the service center did a great job, but someone needs to check quality control. This sucks!!!
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  20. #20

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Location
    Silicon Valley
    Posts
    6,139

    Default

    Quote Originally Posted by BLACKHAMMERJAMM View Post
    No $200 in the box with the new PSW1000.... Well at lease this one makes noise, but the damn volume control is broke... The people at the service center did a great job, but someone needs to check quality control. This sucks!!!

    Will they pay for shipping this time since the service center should have noticed the volume control doesn't work? Did you notice the volume control goes to 11? :)

  21. #21

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    I hope so.. oh I just noticed that 11... I don't want a PSW1000 at all, hopefully I can trade it in for a MicroPro 3000 or 4000. The PSW1000 has way too much port noise (even if you take off the power port plate). I compared my Klipsch sub-12 to the PSW1000 and at half the cost the Klipsch was better for loud HT use. For music and low volume HT the PSW1000 is better.

    for now I have to wait till Gill gets back from vacation to find out about the trade.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  22. #22

    Member Sales Rating: (0)

    Join Date
    Jun 2008
    Posts
    69

    Default

    Gill got back, took care of my request and will be sending me a new MicroPro 4000. WOW that is great service and I don't even have to pay for shipping back this time.
    Sony KDL-52XBR4
    Onkyo Pro PR-SC885P
    NAD T975
    LSIi15's front
    LSIiC center
    LSIiFX's surround
    LSIi15's rear
    PSW1000
    Sony BDPS2000ES
    2nd system
    Sony STRDA5300ES
    Sony PS3
    LSi9's front
    Klipsch sub
    under construction

  23. #23

    Member Sales Rating: (43)

    Join Date
    Nov 2006
    Location
    CT
    Posts
    15,931

    Default

    Sweet. Polk CS rocks!
    Please. Please contact me a ben62670 @ yahoo.com. Make sure to include who you are, and you are from Polk so I don't delete your email. Also I am now physically unable to work on any projects. If you need help let these guys know. There are many people who will help if you let them know where you are.
    Thanks
    Ben

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. LSI 15, LSI C, LSI FX, PSW1000 x 2
    By bdaley6509 in forum For Sale (FS) Classifieds
    Replies: 24
    Last Post: 03-11-2008, 03:31 PM
  2. Any last minute words of advice; NEW GEAR has Arrived!!
    By 64met in forum Basic Hookup/Wiring Questions
    Replies: 9
    Last Post: 12-08-2007, 03:31 PM
  3. 13 minute MGS4 in game demo
    By lanion in forum Video Games
    Replies: 5
    Last Post: 07-25-2007, 10:14 AM
  4. ebay vintage Polks.. last minute bid's drive's price way up
    By danger boy in forum Vintage Speakers
    Replies: 2
    Last Post: 03-09-2006, 11:29 PM
  5. 5 minute Star Trek Nemesis clip
    By Ron-P in forum Music & Movies
    Replies: 8
    Last Post: 11-22-2002, 09:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts