Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3

Thread: melting fuses

  1. #1
    mattharper
    Guest

    Default melting fuses

    i put in a fuse... turn on the stereo and then a few mins later it blows... i have a earthquake amp, 2 polk ex12's and a cap.
    help cause ive been looking for a solution and i cant find one... i thinking im just gonna buy a few hundred fuses:D

  2. #2

    Member Sales Rating: (0)

    Join Date
    Aug 2002
    Location
    Buffalo, NY
    Posts
    3,962

    Default

    well what is the power rating on the amp? take the RMS power of the amp at 2 ohms... divide that by 10... that is the size of the fuse you should have....

    so you got a 1000 watt amp, divided by 10 = 100 amp fuse you need.

    figure out what yours is... if you're putting in fuses that are too small then that is why they're blowing...
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Texas
    Posts
    975

    Arrow fuses

    couple of reasons you may be blowing fuses....
    1) most obvious is a bad ground.
    2) something shorting..maybe pinched during install
    3) improper connection with the amp/cap- seen this before
    4) as vinnie said(dodge) wrong size fuse
    5) too small of a ground 0r legth could possibly do it too.

    best thing to do..is go over every bit of the install 2x to besure all is right....if that fails..may be a bad amp...wich with earthquake...is a possibility
    Peace sells, but who's buying?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts