Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Sep 2001
    Posts
    12

    Question sealed enclosures

    THANKS FOR ALL YOUR HELP ON SUB WOOFER ENCLOSURES . I WENT AHEAD AND MADE MY SEALED ENCLOSURES THEY SOUND AWSOME!! PLEASE HELP WITH A NOISE PROBLEM I HAVE. MY GROUNDS ARE GOOD! A HAVE A PUNCH 400A4(I THINK A4). THE AMP IS STABLE AT 4 CHANNEL @2 OHMS OR 2 CHANNELS @ 4 OHMS(BRIDGED). IM RISKING IT BY RUNNING AT 2 OHMS (BRIDGED)!!! WHEN I TURN UP THE GAINS I GET LOTS OF NOISE OR FLUTTERONLY AT THIS 2OHMS SET UP . WHEN THE AMP IS AT ITS RATED SETTINGS NO NOISE!! FOR A 2 CHANNEL SET UP HOW MUCH POWER SHOULD I BE LOOKING FOR??? SUBS ARE Polk DB10"s, enclosures -sealed

  2. #2
    Jason
    Guest

    Talking

    Db10's... great speakers, by the way, hi my name is Jason. I work with Kim, but he will be out for a couple of days.
    I sounds like you have an air leak. I would push on the cone of the driver and see if the cone oves up fast or slow. If the cone moves up to it's original position quickly than that is an indication that the enclosure has an air leak. If the cone moves up slowly than the enclosure is sealed well. I would also check the spot that the speaker is mounted to. There can be air leaks there.
    Hope this helps. Let me know what you find!
    P.S
    You should have no problems pushing those two subs with that
    amp. Be careful not to over power the subs. If you hear a "fluttering" sound that is usually an are leak, if you hear a "rubbing" sound that is a result of distortion. If you hear that sound turn down the gain of the amp.
    J

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts