Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6

Thread: more help!!!

  1. #1

    Member Sales Rating: (0)

    Join Date
    Apr 2009
    Posts
    15

    Question more help!!!

    i got my new subs and amp in if u look at my other thred my sub stats and the amp stats are in there. but my question is for some reason every so often my sub randomly goes into protect mode idk y what do u think could be causing it?

  2. #2

    Member Sales Rating: (0)

    Join Date
    Sep 2008
    Location
    pa
    Posts
    459

    Default

    u have amp owners manual? or does amp tell you on speaker inputs which channels to bridge? i told u 1 and 2, and 3 and 4. it may say 1 and 3, and 2 and 4.
    Polk MM6501 kick panels, Eclipse cd7200mkll and SW9122 Bomb Box, Cadence A4, A7, CAP5, JL8W3V3

  3. #3

    Member Sales Rating: (0)

    Join Date
    Apr 2009
    Posts
    15

    Default

    its bridged right and it works just sometimes it goes into protect till i turn it off and back on. could it be the heat? i live in NC

  4. #4

    Member Sales Rating: (0)

    Join Date
    Sep 2008
    Location
    pa
    Posts
    459

    Default

    u turn it off, then back on, then its fine? it gets hot? i'm in pa

  5. #5

    Member Sales Rating: (0)

    Join Date
    Apr 2009
    Posts
    15

    Default

    idk if it gets how im just wondering if that could be the problem

  6. #6

    Member Sales Rating: (0)

    Join Date
    Sep 2008
    Location
    pa
    Posts
    459

    Default

    heat is def an enemy of amps and most electronics. if its too hot to touch u may want to think about different mounting options or installing a cooling fan...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts