Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (25)

    Join Date
    Feb 2008
    Location
    West Chester, PA
    Posts
    4,301

    Question Frozen driver (MW6509)- Repairable?

    In my SDA-SRS 2's :(

    As I mentioned in the Wet Look thread, as I was cleaning the drivers, I discovered one was frozen (and no it didn't happen when I was cleaning it).
    The driver was previously working and I hadn't moved them (the whole speaker) at all except to slide them a few inches this way and that adjusting for position.
    I though something wasn't right lately with the sound and stage.

    And when I say frozen solid-I mean it not budging at all.

    Other than from transit, what causes this to happen? Is it simply glue failure?
    I noticed that I was able to move/spin the magnet a bit and I figured well its shot anyway, might as well give it a try; and I pulled the magnet straight off. and now the driver is free again. I don't see any damage to the coils or anything. Measuring just over 9 ohms at the terminals.

    So is there a chance in hell of repairing this myself? Or is reapplying the magnet the hard part?

    Here's a couple shots:



    In this shot the magnet appears off center, but these two still seem to be firmly glued--Should I try to separate and realign?



    If this is possible to repair-what do I do?
    I think gluing up all the other drivers is definitely on my short list of Holiday projects
    ____________________
    This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

    HT:Onkyo 805, Emotiva XPA-5, Mitsu 52" 1080p DLP / polkaudio RTi12, CSIa6, FXi3, uPro4K
    2-chnl : Pio DV-46AV (SACD), Dodd ELP, Emotiva XPA-1s, XPA-2, Odyssey Khartago, LSi9, SDA-SRS 2 , SB Duet, MSB & Monarchy DACs, Yamaha PX3 TT, SAE Tuner...
    Pool: Atrium 60's/45's

  2. #2

    Member Sales Rating: (43)

    Join Date
    Nov 2006
    Location
    CT
    Posts
    15,931

    Default

    You can try realigning it with a jig, but I have had minimal luck doing so.
    Ben
    Please. Please contact me a ben62670 @ yahoo.com. Make sure to include who you are, and you are from Polk so I don't delete your email. Also I am now physically unable to work on any projects. If you need help let these guys know. There are many people who will help if you let them know where you are.
    Thanks
    Ben

  3. #3

    Member Sales Rating: (25)

    Join Date
    Feb 2008
    Location
    West Chester, PA
    Posts
    4,301

    Default

    What kind of jig?
    ____________________
    This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

    HT:Onkyo 805, Emotiva XPA-5, Mitsu 52" 1080p DLP / polkaudio RTi12, CSIa6, FXi3, uPro4K
    2-chnl : Pio DV-46AV (SACD), Dodd ELP, Emotiva XPA-1s, XPA-2, Odyssey Khartago, LSi9, SDA-SRS 2 , SB Duet, MSB & Monarchy DACs, Yamaha PX3 TT, SAE Tuner...
    Pool: Atrium 60's/45's

  4. #4

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,227

    Default

    I don't know of anyone that has successfully repaired a MWxxxx driver with that problem.
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  5. #5

    Member Sales Rating: (0)

    Join Date
    Mar 2003
    Location
    Maryland
    Posts
    2,131

    Default

    I am wondering if the voice coil gets damaged from scraping the magnet after it shifts?
    Stan

    Main 2ch:
    Polk LSi15 (DB840 upgrade)
    Parasound: C/PT-600, HCA-800II; Denon: DVD-2910, DRM-800A; Monster HTS3600-MKII, Grado SR-225i

    HT:
    Denon AVR-888, Polk: RM7, PSW10, Marantz UD5005, Panasonic TC-P42S60

    Other stuff:
    Denon: DRA-835R, DRA-825R, DCD-660, DRM-700A, DRR-780; Polk: RTA11TL (RDO198-1, XO and Damping Upgrades), S8, Monitor 5A, TSi100; Pioneer CT-6R, PL-530; Onkyo CP-1046F; Ortofon OM5E, Marantz PM5004, CD5004

  6. #6

    Member Sales Rating: (43)

    Join Date
    Nov 2006
    Location
    CT
    Posts
    15,931

    Default

    Quote Originally Posted by F1nut View Post
    I don't know of anyone that has successfully repaired a MWxxxx driver with that problem.
    I have, and I remember another Polkie doing it, but after the price of making the jig, and the work the point is mute.
    Please. Please contact me a ben62670 @ yahoo.com. Make sure to include who you are, and you are from Polk so I don't delete your email. Also I am now physically unable to work on any projects. If you need help let these guys know. There are many people who will help if you let them know where you are.
    Thanks
    Ben

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Frozen Monitor 10A Driver
    By softsynth in forum Vintage Speakers
    Replies: 8
    Last Post: 09-23-2009, 04:50 PM
  2. Need Help Model 5's - Driver Midrange Driver frozen
    By Polk5 in forum Vintage Speakers
    Replies: 5
    Last Post: 08-25-2008, 01:41 PM
  3. MW6509 driver needed for testing
    By Kim in forum Vintage Speakers
    Replies: 13
    Last Post: 08-28-2007, 03:22 PM
  4. WTB MW6509 Driver & SW120 Bass Radiator
    By JsTig in forum Wanted (WTB) Classifieds
    Replies: 0
    Last Post: 02-21-2006, 09:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts