Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    Member Sales Rating: (0)

    Join Date
    Mar 2003
    Posts
    10

    Default Can anyone tell me why my sub sounds like crap?

    o, like i have posted before, i bought a 12 inch polk DX sub on ebay, for 35 bucks including shipping. i also bought a sub box from bigdogcaraudio on ebay. So I hook everything up- I put plubers putty inside the part of the sub that the screw go, i pre-drilled my holes, and everything, but I tested on my friend's kenwood amp and it just sounded crappy. And then, I tested it on my brother's home stereo via the powered sub output, and it sounded alright, but it was only being fed 100 watts, and its a 4 ohm sub on an 8 ohm stereo so maybe it was beeing pushed more. But I just can't figure it out! Maybe my sub is just a piece of junk


    Anywho, I tok the sub out and took all the putty out. Then i Looked in it and there was not alot of little dust. The box is still good though. One screw i screwed in crooked and it screwed inward toward the sub, so there is this little pierce there that is no problem.

    Now, i may put my sub back in, and what i was going to do it hot glue all the holes that are already in it, fill them up so air wont get out, then i will just place the sub in the box, pre-drill new holes, then just put the wood screws in. after that, i will apply the plumber's putty around the sub once it is atached to the box. but i know my box is fine, i just dont think I can use the same screw holes. I may upgrade to shorter screws, i was thinking maybe 3/4 long or maybe 5/8.

    well, this is my delema, any help would be greatly appreciated, i am heading on a little road trip to cedar point soon and i just wanted to try and get my system up and running


    thank you for your reply
    Whoa! Denied!

  2. #2

    Member Sales Rating: (0)

    Join Date
    Aug 2002
    Location
    Buffalo, NY
    Posts
    3,962

    Default

    well... u're problem is'nt the screws dude... and u can prolly use the same screw holes... and seal it the way u did last time, dont seal it after its already in the box or else it wont even seal properly.

    if your home stereo does 100 @ 8 ohms it probably does 175 - 200 @ 4 ohms... most good home stereos if they are 4 ohm stable will just about double into 4 ohms.

    u've gotta ask yoruself a few questions...
    1- how much power is that kenwood amp putting out? (is it at least 300 rms)?
    2- what is the internal air space of that box you bought? (is it 0.88 cubes or about that ?)
    3- how are u facing the box ... forard, backward, up, down, what? and what kind of car is this in? pointing of the sub is important.
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag

  3. #3

    Member Sales Rating: (0)

    Join Date
    Mar 2003
    Posts
    10

    Default well..

    ok, it is kenwood amp and my friend does not know how many watts it pushes, why he does not know i do not understand. Anywho, he runs two 12" MTX 5000's and he bridges the amp. The subs sound really good, so i am going to guess around 300 or 400 rms. When he hooked it up, the sub was facing sideways with the trunk open, and it was forward-firing. it was facing the right, not forward or back. and he drives a '90 chevy cavalier. The box is sealed and exactly .88 cubic feet. And it just did not have the sound quality I anticipated. Now, when ever the bass hits, I heard this clunking noise, (i also did hear that on the home stereo, it just was no as obvoious')as if i were pushing it to hard. He did turn his sub out on his cd player all the way up. but i am not sure on how high the volume was.

    Keep in mind i bought this sub for 35 dollars on ebay, maybe the owner just abused it, but he said that it was in great condition and he gave it a final sound test before he shipped it. And front of the sub looks a little wore, but not damaged at all. I took it out of the box and it looks perfect, i think i might have done something wrong but idk. If the problem persists i might just get a MOMO or an MTX 8000. One problem I can think of is a possible air leak. I predrilled my holes, bu i do not think my screw went though them, basicly there maybe be 16 litle holes in my box. but the box is perfect. IT is still good. I think I may just seal up the holes and drill new ones anyway. One hole i drilled crooked and it cut into the ring, you can plainly see it now.

    Well hope this info helps, If i still canot get it right I may just get a momo. I saw some brand new ones on ebay for $140! thats a good deal
    Whoa! Denied!

  4. #4
    PBD
    Guest

    Default

    well from what you said it sounds like you should have at least enough to get the sub moving in a normal fashion.

    hmm...

    the clunking thing isnt good... chances are the voice coil is shot if its doing that.

    push down on the center of the sub evenly .. if u hear any rubbing or grinding thats a sure indication.

    clunking more often than not is a dead sub.

    whatever udo dont buy an mtx 8000 -- those things are horrible.... by far one of the worst subs ive ever heard.

    theyre are some mtx 7000's at the mitek factory outlet online store for 140 bucks -- they're 15" single 4 ohm coil brand new in the box with 1 year warranty from mtx.

    also if u're dead set on a 8k -- u can get one for like 50 bucks from that outlet which is run by the people who build the subs in the first place -- everything has at least a 90 day warranty.

    i wouldn't get a momo unless i had at least 500 W to push it with -- or else 1) it wont get loud enough 2) you're gonna beat on it trying to make it louder 3) you're gonna bust it.

    lose the kenwood, get something with some umph.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Mar 2003
    Posts
    10

    Default r

    ok, i did what you said and it aint good.
    i heard this noise when i pushed the cone in, kinda sounded like a rusty sound :supermad:

    well, that idiot on ebay said the sub was in great condition and it souned great, what a liar. Next time i buy stereo stuff on ebay i will but it brand new:supermad:

    well, i still have a little faith in it. I will re-do things on my sub and try to get it working, but idk. Is it possible to fix a sub where the voice coil is broken/shot? an mtx 8000 or 7000 looks good for me though, my ghetto boss rev-635 is 400x1 bridged so ima have to get a 12' sub with 400 wats RMS.
    Whoa! Denied!

  6. #6

    Member Sales Rating: (0)

    Join Date
    Aug 2002
    Location
    Buffalo, NY
    Posts
    3,962

    Default

    is that boss 400 max or 400 rms bridged? if its 400 max, then get a sub thats 200 - 250 rms (rms = 1/2 max).

    far as the dx -- once the coil is shot the sub is not.... they are not rebuildable subs. some speakers are assembled in a manner that they can be torn down and rebuilt... in such a case, when the coil goes, they will usually replace it along with the cone and surround, which are all one piece. the spider as well... all that remains original is the magnet(s), the basket, and the terminals.

    this usually costs 1/3 - 1/2 of the retail price of the sub. for example, i can get my idmaxes "rebuilt" for 175 bucks. not that i'd ever need to have that done just yet, but its nice to be able to do down the line (assuming parts are still available in a few years).

    the mtx 7000 15" really aint a bad buy for 150 bucks brand new with a 1 yr warranty... thats probably the cheapest 400 - 500 watt rms 15" sub you're going to find, and its built pretty darn well. the 7000's were a helluva lot better than the 8000's... only problem with the 7000' sis that they're ugly as sin... just flat black, nothin pretty about them at all... kinda like a DX without the smooth finish and without the blue lettering.
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag

  7. #7

    Member Sales Rating: (0)

    Join Date
    Mar 2003
    Posts
    10

    Default thanks

    thanks everyone for helping, i have now learned my lesson on online auctions, ONLY BUY BRAND NEW ITEMS:supermad:

    When I push in on the cone, i can bearly hear that noise, it has to be REALLY quiet for my to hear it, I will install in once more, and if no i am pitching the bastard!

    Anywho, I am looking at either an MTX 7000 or 8000
    Since my box is in perfect conditon now, I'll try and find a 12'
    my boss amp is 400 watts RMS bridged, and i think it peaks out at 800 or 900 but im not sure. I also saw some polk momos at a good price(brand new ofcourse), but i will not be able to push them fully becase the handle 500 RMS. Like PBD said, i might get mad and want it to sound louder, risking me blowing it.

    WEll thanks again for the help, i only lost 30$ which aint that bad
    Whoa! Denied!

  8. #8
    japs2112
    Guest

    Default

    I'm no expert but i would say that you can get a couple of 12" gnx subs at crutchfield for 160 dls powering them with 400 rms bridged (it's like 200 rms per channel) depending on the rest of your setup you'll be fine, but youll still have to build the box for them, i have a pair of EXII (PBD helped me a while ago with some comments) and they hit hard with 205 rms each on a ported box, so you have another option here, hope it helps

  9. #9

    Member Sales Rating: (0)

    Join Date
    Aug 2002
    Location
    Buffalo, NY
    Posts
    3,962

    Default

    try some pioneer dual 4 ohm coil subs -- www.ikesound.com -- u can get two 10's for 80 bucks shipped total -- 40 / sub.

    if u wire them up to 8 per sub then parallel them that's 4 ohm load --- so u'll get 200 per sub...

    i was gonna do that with two of those pionners and an mtx 302 (425 x 1 bridged @ 4). but then i found some DX's cheap ---

    BUT THEN I GOT SCREWED IN THE POOPER TOO!!!!!!!

    the guy who was sposed to get me the DX's ended up only having one -- so he charged me for one and then i got stuck having to find another one or else i was f*****.

    so after hunting 20 merchants i ended up having to beg the guys at polk customer service to hook me up with one -- god bless them that they were able to -- but it cost me 132 bucks -- which really burns me cuz i was countin on the 65 that the other dude had charged me.. but at least i got em.
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts