Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    3

    Default PSW350 No Power & Blows Fuse

    I have a PSW350 and it gets no power. I opened it up and voila, fuse is blown. I bought a new fuse, put it in, and the second I plugged it in to the wall (with the power switched to off) the fuse blew again. Any help, advice, or direction would be greatly appreciated. Looks like I'm not the first with this issue on a sub...

  2. #2

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    3

    Default

    Alright, upon further investigation, I have found the problem...

    Here is the problem. There are 4 of these (whatever they are). There is some burning between the middle 2 toward the outside edge of the board. (I apologize for not having a better res camera btw.)


    Here is the overall pic so you can see where and what I'm talking about. The problem is on the upper right hand corner of the board in this pic.


    Here is a pic taken from that same corner on the back side of the same board.


    Any help, direction, or advice would be greatly appreciated as well as a schematic.

    Thank You...

  3. #3

    Member Sales Rating: (0)

    Join Date
    Oct 2009
    Posts
    32

    Default

    from the picture I can't see it very well ,it looks like four resistors,first off if it is still under warranty ,I would put it back together and try to get a RMA ,I think the amp has a three year warranty.If the warranty is out then I would go to radio shack or some where where you can buy those resistor and get a soldering iron and take them all off.and see if you can clean it up,so you can solfer the new ones on.But if your PCB board is to damage and you have nothing to solder to..It looks like they were so close together it may have arc two of them and then just got to hot and shorted out.
    ONKYO TX-SR607
    PolkAudio Speakers
    Front-Monitor 70's
    Center-CS2
    Sur-round-Monitor 40's
    Sur-round Back-Monitor 60's
    Subwoofer-PSW-505
    Back fill in Bass PSW-10
    LG 50"Black 1080P Plasma HDTV (50PS60)
    LG Blu-Ray Disc BD390

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help main power fuse
    By hitenskins in forum Basic Hookup/Wiring Questions
    Replies: 3
    Last Post: 12-13-2008, 01:48 PM
  2. Replies: 1
    Last Post: 01-08-2008, 03:44 PM
  3. no power to sub so replaced the fuse and the fuse kept on blowing?????
    By newbie2k8 in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 01-08-2008, 09:41 AM
  4. New fuse for my PSW350???
    By BRAD-TX in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 06-03-2003, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts