Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 14 of 14
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    10

    Default PSW 505 crossover settings

    Hey guys, new to the forums and in need of some help. I've had my set up for a few years now and just moved= new room for speakers. So now that i've been toying with everything i've been trying to tweak the audio settings. I just noticed that my crossover settings do not seem to change when i turn the knob on the back of the subwoofer. I had a monster sub cable connecting my sub to my Onkyo (i forget the model, sorry) receiver. It's to the unfiltered plug on the sub. I tried changing the crossover on the receiver, nothing. Tried it on the sub, nothing. Tried hooking the sub up with the two RCA's to the filtered inputs and tweaked the x-over on the sub, nothing. Is there a NOTICABLE difference from 60-125hz on the settings? I don't hear much of a difference if at all. Thanks for the help

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Location
    Tucker,GA
    Posts
    416

    Default

    What are you listening to while checking it? Find some music with a lot of bass guitar etc. Then you will definitely be able to tell the difference in the settings. Also, when connected to the LFE input on the sub, the Crossover on the sub will be disabled. I hope that helps:)
    Sony 40" LCD
    Sony DVPCX995V
    Sony PS3(games/media server)
    Sony PS2
    WD TV Live with 3TB
    Sanyo VCR
    Marantz SR6003
    Polk 11T(xover/RDO)
    RM20 5 pack
    OWM 5
    DUAL Micro Pro 1000
    Combastard Cable
    Harmony One
    -------------------------
    When rapture comes, can I have your car?

  3. #3

    Member Sales Rating: (4)

    Join Date
    Feb 2007
    Posts
    6,974

    Default

    I think when you run LFE direct, the crossover has no effect on the sub.
    polkaudio RT35 Bookshelves
    polkaudio 255c-RT Inwalls
    polkaudio DSWPro550WI
    polkaudio XRT12 XM Tuner
    polkaudio RM6750 5.1

    Front projection, 2 channel, car audio... life is good!

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    10

    Default

    Yea I read through the manual and contacted polk and that's what they said (about the x-over not working with the LFE) but that's when I hooked it up with the red and white RCA's and still no adjustability... and i was listening to music with bass guitar, vocals, drums and wasn't able to detect any difference... will try again though when I get home.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Oct 2009
    Location
    United States
    Posts
    8

    Default PSW 505 crossover settings

    Has anyone been able to get this to work? I have tried the different settings listed with no luck.

  6. #6

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Location
    Tucker,GA
    Posts
    416

    Default

    It sounds like the receiver settings are the culprit here. When using the LFE, the sub crossover is not used. The crossover on the receiver IS and that's what you need to adjust if you use the LFE. If you are using the regular RCA, make sure the receiver has the fronts set to large, otherwise it will not send the bass to the sub, or may be sending only 60/80hz and above etc... We can help you much more if you tell us the model of your receiver, and tell us what the settings are on:)
    Sony 40" LCD
    Sony DVPCX995V
    Sony PS3(games/media server)
    Sony PS2
    WD TV Live with 3TB
    Sanyo VCR
    Marantz SR6003
    Polk 11T(xover/RDO)
    RM20 5 pack
    OWM 5
    DUAL Micro Pro 1000
    Combastard Cable
    Harmony One
    -------------------------
    When rapture comes, can I have your car?

  7. #7

    Member Sales Rating: (0)

    Join Date
    Mar 2006
    Location
    Sydney AUSTRALIA
    Posts
    257

    Default

    Just try it what was referred to as the "Polk way". Run your front speakers through your line in and line out connections on the PSW505. Tell your receiver that you have "no" sub and that your front speakers are large. I never use the LFE out on any AVR and have always hooked it up the Polk way. All your controls are then via the PSW505 crossover and volume controls - give it a shot and let us know how you go.
    Regards - Gaz from the land of Oz

    Main
    Denon AVR-4520
    Emotiva MPS-2 7 Channel Amp (driving all LSi's)
    Emotiva XPA-2 (driving RTiA9s)
    Cambridge Audio Azur 851C / 850E / 752-BD
    Polk Audio Cherry LSi9s - LSiC - Cherry LSi7s - PSW505 - RTiA9s
    Panasonic TH-P60UT50A 60' 3D Plasma
    Foxtel Digital HD+
    Belkin - Pure AV PF40

    Bedroom
    Denon AVR-3808
    Denon DVD-3930
    Polk Audio SurroundBAR - PSW250
    Fujitsu P42HHS10W/P42HHS10A 42' HD Plasma - HD STB

  8. #8

    Member Sales Rating: (1)

    Join Date
    Oct 2008
    Location
    Descending toward the moon in the CLEM (Chinese Lunar Excursion Module), looking for Chang'e
    Posts
    11,463

    Default

    You need to get into the Onkyo crossover and level menus in order to boost the LFE signals out. It's not hard, there are buttons on your remote...just start with the Test tone button and move the signal to the sub..then use the + and - buttons to the immediate right to raise the VOLUME of the sub signal.

    You must also, if you haven't yet. TELL the AVR that you have a sub. Do you see a sub icon in the Onkyo display panel? If not find that menu and say Sub YES!

    There is also a crossover menu? Look at your manual--all this is in there.


    cnh

  9. #9

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    10

    Default

    unfortunately, i'm at work again...so i'm not by my setup. but my receiver is a tx-sr674 and i would assume the receiver "sees" the sub or knows it's on because i can adjust the subwoofer db, and in one of the audio menus it shows the crossover setting for the sub. On the receiver i set the x-over higher than 120 and as low as it went and i dont remember hearing a difference... again, i have the sub connected through the LFE connection and to the receiver's sub-out. has anybody here tried the "polk way" method? i'm interested

  10. #10

    Member Sales Rating: (0)

    Join Date
    Mar 2006
    Location
    Sydney AUSTRALIA
    Posts
    257

    Default

    Quote Originally Posted by evolutionix View Post
    unfortunately, i'm at work again...so i'm not by my setup. but my receiver is a tx-sr674 and i would assume the receiver "sees" the sub or knows it's on because i can adjust the subwoofer db, and in one of the audio menus it shows the crossover setting for the sub. On the receiver i set the x-over higher than 120 and as low as it went and i dont remember hearing a difference... again, i have the sub connected through the LFE connection and to the receiver's sub-out. has anybody here tried the "polk way" method? i'm interested
    Polk used to have the "Polk Way" on their educational pages on this site, for which is no longer there. I haven't seen it for a few years, but maybe some of the more senior member's maybe able to link back to it.

    BTW, Happy New Year to all - already into our 8th hour of 2010 in Sydney :)
    Regards - Gaz from the land of Oz

    Main
    Denon AVR-4520
    Emotiva MPS-2 7 Channel Amp (driving all LSi's)
    Emotiva XPA-2 (driving RTiA9s)
    Cambridge Audio Azur 851C / 850E / 752-BD
    Polk Audio Cherry LSi9s - LSiC - Cherry LSi7s - PSW505 - RTiA9s
    Panasonic TH-P60UT50A 60' 3D Plasma
    Foxtel Digital HD+
    Belkin - Pure AV PF40

    Bedroom
    Denon AVR-3808
    Denon DVD-3930
    Polk Audio SurroundBAR - PSW250
    Fujitsu P42HHS10W/P42HHS10A 42' HD Plasma - HD STB

  11. #11
    Banned
    Member Sales Rating: (0)

    Join Date
    Apr 2009
    Location
    France and Costa Rica
    Posts
    987

    Smile

    Quote Originally Posted by VXR8 View Post
    Polk used to have the "Polk Way" on their educational pages on this site, for which is no longer there. I haven't seen it for a few years, but maybe some of the more senior member's maybe able to link back to it.

    BTW, Happy New Year to all - already into our 8th hour of 2010 in Sydney :)
    http://www.polkaudio.com/forums/arch...hp/t-8533.html

    http://www.polkaudio.com/forums/showthread.php?t=8533
    Last edited by Bernal; 01-02-2010 at 03:59 PM.

  12. #12

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    10

    Default

    Awesome! Thanks bernal

  13. #13

    Member Sales Rating: (0)

    Join Date
    Oct 2009
    Posts
    32

    Default

    The crossover on the PSW-505 only works if you use the red and white RCA input.If you use the LFE input the crossover on the sub does not work because your reciever it what would set the crossover.you should be able to hear the difference between 60hz and 120hz unless you have your reciever set to a low crossover point.
    ONKYO TX-SR607
    PolkAudio Speakers
    Front-Monitor 70's
    Center-CS2
    Sur-round-Monitor 40's
    Sur-round Back-Monitor 60's
    Subwoofer-PSW-505
    Back fill in Bass PSW-10
    LG 50"Black 1080P Plasma HDTV (50PS60)
    LG Blu-Ray Disc BD390

  14. #14

    Member Sales Rating: (0)

    Join Date
    Jan 2010
    Posts
    6

    Default Fyi

    FYI y'all- I e-mailed Polk, asked why the PSW 505 manual says to hook up the subwoofer with front speaker line-outs, when their website tutorial says to hook up receiver sub-out to sub LFE in, and they said that the instructions for using line-out to sub were written before most consumer-level receivers had standard sub-out rca jacks. So, bottom-line is the 'New Polk Way' is to connect sub-out to LFE-in via RCA jack. Hope this helps

    Lute

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Crossover Settings
    By camel_89si in forum Speakers
    Replies: 6
    Last Post: 06-15-2009, 02:40 PM
  2. LSi15 crossover settings
    By reberly in forum Troubleshooting
    Replies: 5
    Last Post: 11-15-2007, 01:26 PM
  3. Crossover settings
    By Sutho_ in forum Car Audio & Electronics
    Replies: 1
    Last Post: 09-19-2007, 06:58 PM
  4. crossover settings, need some help
    By danger boy in forum Speakers
    Replies: 1
    Last Post: 10-25-2006, 03:05 AM
  5. Crossover Settings
    By MikeT66 in forum Subwoofer Hookup & Bass Management
    Replies: 3
    Last Post: 05-31-2004, 07:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts