Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    2

    Default Subwoofer isn't working properly-help needed.

    Hello everyone,

    I am new to this forum. I have a Polk Subwoofer PSW12 hooked up to a Onkyo TX-SR702 receiver. I noticed today the bass isn't hitting as hard like it used to.

    I tried turning the volume on the back of sub all the way up and there's bass coming out but is very subtle. I checked all the connections and everything is hooked up correctly. When I unplug the sub cable then plug it back in to the receiver, the bass sounds good when the connection from the cable touches the outside of the plug. I did a speaker test and the sub also sounds good, but during normal use of watching TV, listening to music and gaming.....it's like there is no bass at all. What's going on???

    Any feedback would be appreciated.

    Thank you,
    Tran

  2. #2

    Member Sales Rating: (14)

    Join Date
    Jan 2009
    Location
    Southeast Va in the 757
    Posts
    3,574

    Default

    Im assuming no settings have changed on your AVR, aside from possible sub damage, have you tried a different IC?

    Oh yeah...welcome to CP!
    Polk Audio Surround Bar 360
    Mirage PS-12
    LG BDP-550
    Motorola HD FIOS DVR
    Panasonic 42" Plasma
    XBOX 360[/SIZE]

    Office stuff

    Allied 395 receiver
    Pioneer CDP PD-M430
    RT8t's & Wharfedale Diamond II's[/SIZE]

    Life is one grand, sweet song, so start the music. ~Ronald Reagan

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Location
    Tucker,GA
    Posts
    416

    Default

    It sounds like a bad cable, make sure the metal part(connection part) is not pushed in to the point that it's touching the metal on the back of the sub or receiver. If it's not that, then the RCA(sub) connection on the sub or receiver may be shorted out? Let us know what you find:)
    Sony 40" LCD
    Sony DVPCX995V
    Sony PS3(games/media server)
    Sony PS2
    WD TV Live with 3TB
    Sanyo VCR
    Marantz SR6003
    Polk 11T(xover/RDO)
    RM20 5 pack
    OWM 5
    DUAL Micro Pro 1000
    Combastard Cable
    Harmony One
    -------------------------
    When rapture comes, can I have your car?

  4. #4

    Member Sales Rating: (15)

    Join Date
    Jun 2008
    Location
    Indianapolis, IN
    Posts
    7,407

    Default

    I think it may be the infamous Onkyo Double Bass scenario. My sub did absolutely nothing outside of test tones until i enabled that setting when i had my Onkyo.
    I don't read the newsssspaperssss because dey aaaallllllllll...... have ugly print.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    2

    Default

    Thank you everyone for your responses. I will have to run out and get a new sub cable tomorrow. Does the quality matter on sub cables?

    Sorry for this newb question on cables...is a digital coaxle the same as a sub cable?
    Last edited by TTran; 12-29-2009 at 11:06 PM.

  6. #6

    Member Sales Rating: (14)

    Join Date
    Jan 2009
    Location
    Southeast Va in the 757
    Posts
    3,574

    Default

    Wow! Thats a question you may get 1000 responses for!:p I would pick up a good quality cable locally, see if that helps, if thats the cure, maybe order 1 from Monoprice, Blujeans etc.....

    As for your question....a RCA cable will work.
    Last edited by Knucklehead; 12-30-2009 at 12:10 AM.
    Polk Audio Surround Bar 360
    Mirage PS-12
    LG BDP-550
    Motorola HD FIOS DVR
    Panasonic 42" Plasma
    XBOX 360[/SIZE]

    Office stuff

    Allied 395 receiver
    Pioneer CDP PD-M430
    RT8t's & Wharfedale Diamond II's[/SIZE]

    Life is one grand, sweet song, so start the music. ~Ronald Reagan

  7. #7

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Location
    Tucker,GA
    Posts
    416

    Default

    I with knucklehead on this one, just try any RCA cable, and then get a better one later if you determine that IS the problem:)
    Sony 40" LCD
    Sony DVPCX995V
    Sony PS3(games/media server)
    Sony PS2
    WD TV Live with 3TB
    Sanyo VCR
    Marantz SR6003
    Polk 11T(xover/RDO)
    RM20 5 pack
    OWM 5
    DUAL Micro Pro 1000
    Combastard Cable
    Harmony One
    -------------------------
    When rapture comes, can I have your car?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Subwoofer not working
    By fpw63 in forum Troubleshooting
    Replies: 3
    Last Post: 06-28-2009, 10:59 AM
  2. Need Help Subwoofer not working - RM670
    By sonixusa in forum Subwoofer Hookup & Bass Management
    Replies: 5
    Last Post: 06-14-2009, 07:47 PM
  3. Subwoofer not working... plz help :(
    By craigCDC in forum Car Subwoofer Talk
    Replies: 2
    Last Post: 03-21-2009, 03:00 PM
  4. PSW110 not working properly
    By brunell in forum Troubleshooting
    Replies: 0
    Last Post: 01-17-2009, 10:41 AM
  5. RM6000 - Subwoofer no working
    By crewmark in forum Troubleshooting
    Replies: 12
    Last Post: 08-27-2006, 12:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts