Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Posts
    22

    Default NO left sound in AV receiver

    Hello,

    I have a Yamaha htr-5280. There's no sound coming to the left channel on the receiver. I tried with external amp, but it still doesn't work. I can hear static coming out from left channel when turning the volume nob up and down. It does sometimes play for a few seconds if I shake it.

    What I figured out:

    The whole left channel is not working, not just the amp section, but the preout left channel as well.

    Help!

  2. #2

    Member Sales Rating: (1)

    Join Date
    Sep 2009
    Location
    Texas
    Posts
    785

    Default

    The Yammy needs a trip to a repair shop .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. RB-1080 no sound on left channel
    By Tomasito in forum Electronics
    Replies: 7
    Last Post: 12-28-2009, 01:14 PM
  2. I only hear the left when my computer is hooked to receiver
    By Home Theatre in forum Basic Hookup/Wiring Questions
    Replies: 3
    Last Post: 10-03-2007, 03:28 PM
  3. RTi8s - why does left sound different from right?
    By Spiderninja in forum Speakers
    Replies: 13
    Last Post: 03-03-2006, 09:07 AM
  4. Replies: 5
    Last Post: 01-01-2006, 02:41 AM
  5. Replies: 0
    Last Post: 09-11-2004, 06:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts