Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Apr 2010
    Posts
    5

    Exclamation 13w7 Distorting???

    My system:
    4runner
    Pioneer avh 6050dvd Head unit
    1 Polk Audio sr 6500 (getting the other pair probably)
    2 JL Audio 13w7
    1 Alpine pdx 1.1000 (hooked to 1 sub, getting another amp of this)
    1 Apline pdx 4.150

    The subwoofers sound pretty nice but... When I need it to be loud it produces some kind of weird noise (not in every song). Ive been researching and it is maybe because of the poor signal strenght... the head unit is pretty nice, it has 4v preamp, but the RCAs are 7meters long and ive been thinking that there must be the problem... If there is... What should I do? a buy a subwoofer processor? like the Soundstream Bx-20z? or the Powerbass Xba-2? or the kicker KQ30? all of them increase the preamp power (In case that it is what Im needing) I want SQ and some strong bass... If there is anything you know about how to improove the SQ, please let me know, my speakers signal might have the same problem even when they arent distorting much...

    Thanks for the help...

  2. #2

    Member Sales Rating: (0)

    Join Date
    Oct 2004
    Location
    North Texas
    Posts
    5,596

    Default

    Set the gains properly like I mentioned in your other thread. I think thats the bulk of your problems right now.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2010
    Posts
    30

    Default help

    its the pdx. I have the exect same amp and it just won't run right. I bouth the pdx and to alpine type x ran off a alpine 9887. It just doesn't like to work. THe amp was shipped with the wrong fuse's check them first they should be 25's not 20. If you can get the pdx to work right it is great, but its very fickle and just not worth the time. hell i will sell you mine if you are instresed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Tweeter popping sound, distorting sort of?
    By c_corie in forum Troubleshooting
    Replies: 5
    Last Post: 02-09-2008, 05:50 PM
  2. cs1 distorting/cracking
    By .Jon in forum Troubleshooting
    Replies: 8
    Last Post: 05-20-2006, 12:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts